Increased error rate for websites behind Cloudflare

Incident Report for HetrixTools

Resolved

Cloudflare has updated the status of their incident to resolved.

We're noticing that the number of 520 HTTP errors from HEAD requests has gone down.

This incident is now resolved.
Posted Mar 18, 2026 - 15:14 UTC

Identified

We've been observing an increased rate of 520 HTTP errors from HEAD requests to websites behind Cloudflare.

Cloudflare has recently acknowledged the issue on their end and is working on a fix:
https://www.cloudflarestatus.com/incidents/kxvggpg7kwx5

In the meantime, you can fix the issue right away in your HetrixTools account by changing the "HTP Method" from "HEAD" to "GET" for any of your website monitors (by editing the monitor's settings): https://docs.hetrixtools.com/wp-content/uploads/2022/10/image.png

You can check if you're affected by this Cloudflare issue by checking your Location Fail Log (https://docs.hetrixtools.com/location-fail-log/) and looking for 520 HTTP errors.
Posted Mar 18, 2026 - 12:20 UTC
This incident affected: Uptime Monitoring.