The scheduled maintenance has been completed earlier than initially expected. All systems are now back to being fully operational.
Posted Mar 08, 2026 - 08:10 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2026 - 06:45 UTC
Scheduled
We will be performing scheduled maintenance on core components of our platform. There will be some service disruptions during this time for the affected components.
Posted Mar 02, 2026 - 12:55 UTC
This scheduled maintenance affected: Uptime Monitoring, Server Agent Metrics, and Notifications.