Email Notification Issues

Incident Report for HetrixTools

Resolved

The Email Queue has caught up with its backlog and is now functioning as expected.
Posted Oct 20, 2025 - 18:36 UTC

Update

We implemented a fix, and the Email Queue is now functioning properly and catching up on its backlog.
We're monitoring it to make sure everything works as expected.
Posted Oct 20, 2025 - 18:07 UTC

Identified

We have identified the issue and are currently working on a fix for it.

Impact: Daily/Weekly/Monthly Reports and Blacklist Monitoring Notifications may be delayed while we fix the issue.
Posted Oct 20, 2025 - 17:50 UTC

Investigating

We are currently investigating an issue where some Email notifications might be sent multiple times due to ongoing AWS Issues.
Posted Oct 20, 2025 - 17:32 UTC
This incident affected: Blacklist Monitoring and Notifications.