AWS Issues

Incident Report for HetrixTools

Resolved

This incident has now been fully resolved.
Posted Oct 20, 2025 - 10:36 UTC

Monitoring

We're seeing no more errors related to the AWS outage. We're still monitoring the situation to make sure that our systems are fully recovered.
Posted Oct 20, 2025 - 09:23 UTC

Identified

The incident has been identified and confirmed by AWS, as per their status page: https://health.aws.amazon.com/health/status

We're working on mitigating the impact on our end while they work on solving the root cause of the problem.
Posted Oct 20, 2025 - 07:36 UTC

Investigating

We are currently investigating connectivity issues with AWS infrastructure in North America. This can cause some parts of our platform to load up slowly or time out.
Posted Oct 20, 2025 - 07:03 UTC
This incident affected: Dashboard, Blacklist Monitoring, Server Agent Metrics, Notifications, and API.